The following is a list of the software/clients prerequisites as of version 7.3 SP4:

  •  Windows OS (7, 8  or 10). 
  •  Standard Web browser Internet Explorer 11 (Compatibility mode required, may also require the PRISM website to be added as a trusted site), Google Chrome or Microsoft Edge.
  •  Adobe Acrobat Reader 2015 to 2018.

*Note: 

These are minimum recommendations and serve as a guideline. Actual system requirements will vary depending on the scope and scale of your implementation. The exact configuration you need to support your environment with satisfactory performance will greatly vary depending on multiple factors such as number of concurrent users, network speed, server speed, memory, disk I/O, data volumes, network and server loads, end-user workstation factors, network and security architecture, and other factors.