If your agency has upgraded to 7.3 Service Pack 4, you now have multiple web browser options to choose from. 


The following browsers are now compatible with the application:

  • Internet Explorer (Users may now turn off Compatibility Mode and Trusted Sites) 
  • Microsoft Edge
  • Google Chrome 


Additionally, in previous versions of PRISM, Compatibility Mode and Trusted Sites in Internet Explorer was required in order to prevent performance issues from occurring. Now, if you choose to use Internet Explorer, Compatibility Mode and Trusted Sites are no longer required.